summaryrefslogtreecommitdiffstats
path: root/kopete/plugins/nowlistening/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kopete/plugins/nowlistening/CMakeLists.txt')
-rw-r--r--kopete/plugins/nowlistening/CMakeLists.txt89
1 files changed, 60 insertions, 29 deletions
diff --git a/kopete/plugins/nowlistening/CMakeLists.txt b/kopete/plugins/nowlistening/CMakeLists.txt
index 29c1e03e..d0e69788 100644
--- a/kopete/plugins/nowlistening/CMakeLists.txt
+++ b/kopete/plugins/nowlistening/CMakeLists.txt
@@ -1,13 +1,13 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
+###########################################
+# #
+# (C) 2010-2011 Serghei Amelian #
+# serghei (DOT) amelian (AT) gmail.com #
+# #
+# Improvements and feedback are welcome #
+# #
+# This file is released under GPL >= 2 #
+# #
+###########################################
include( ConfigureChecks.cmake )
@@ -18,7 +18,7 @@ include_directories(
${CMAKE_SOURCE_DIR}/kopete/libkopete/ui
${TDE_INCLUDE_DIR}
${TQT_INCLUDE_DIRS}
- ${XMMS_INCLUDES}
+ ${XMMS_INCLUDE_DIRS}
)
link_directories(
@@ -26,32 +26,63 @@ link_directories(
)
-##### other data ################################
+##### kopete_nowlistening (module)
-install( FILES kopete_nowlistening.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES kopete_nowlistening_config.desktop DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog )
-install( FILES nowlisteningconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
-install( FILES nowlisteningui.rc nowlisteningchatui.rc DESTINATION ${DATA_INSTALL_DIR}/kopete )
+tde_add_kpart( kopete_nowlistening MODULE AUTOMOC
-
-##### kopete_nowlistening (module) ##############
-
-tde_add_kpart( kopete_nowlistening AUTOMOC
SOURCES
- nowlisteningconfig.kcfgc nowlisteningplugin.cpp nlkscd.cpp
- nlnoatun.cpp nlxmms.cpp nowlisteningguiclient.cpp nljuk.cpp
- nlamarok.cpp nlkaffeine.cpp
- LINK kopete-shared ${XMMS_LIBS}
+ nowlisteningconfig.kcfgc
+ nowlisteningplugin.cpp
+ nlkscd.cpp
+ nlnoatun.cpp
+ nlxmms.cpp
+ nowlisteningguiclient.cpp
+ nljuk.cpp
+ nlamarok.cpp
+ nlkaffeine.cpp
+ LINK
+ kopete-shared
+ ${XMMS_LIBRARIES}
+
DESTINATION ${PLUGIN_INSTALL_DIR}
)
-##### kcm_kopete_nowlistening (module) ##########
+##### kcm_kopete_nowlistening (module)
+
+tde_add_kpart( kcm_kopete_nowlistening MODULE AUTOMOC
-tde_add_kpart( kcm_kopete_nowlistening AUTOMOC
SOURCES
- nowlisteningprefs.ui nowlisteningpreferences.cpp
- nowlisteningconfig.kcfgc
- LINK tdeutils-shared
+ nowlisteningprefs.ui
+ nowlisteningpreferences.cpp
+ nowlisteningconfig.kcfgc
+ LINK
+ tdeutils-shared
+
DESTINATION ${PLUGIN_INSTALL_DIR}
)
+
+
+##### other data
+
+tde_create_translated_desktop(
+ SOURCE kopete_nowlistening.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kopete-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE kopete_nowlistening_config.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/tdeconfiguredialog
+ PO_DIR kopete-desktops
+)
+
+install(
+ FILES nowlisteningconfig.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)
+
+install(
+ FILES nowlisteningui.rc nowlisteningchatui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kopete
+)