summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-11-27 10:42:58 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-11-27 16:02:04 +0100
commita88837a2397f347c9f4c9afec75f9e303e8bbb1e (patch)
treeb49ae3932dfd7ed9861308ce91b38f2183ab85b0 /CMakeLists.txt
parent5c73ac2aefe73dcf88a689be8792528618e54e48 (diff)
downloadkonversation-a88837a2397f347c9f4c9afec75f9e303e8bbb1e.tar.gz
konversation-a88837a2397f347c9f4c9afec75f9e303e8bbb1e.zip
Copy translations to a new directory layout.
Use common rules for build and install translations. Use common rules for build and install documentation. Added translation of .desktop files. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a1767c1..e17a7ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ tde_setup_paths( )
##### optional stuff ############################
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_XSCREENSAVER "Enable xscreensaver support" ${WITH_ALL_OPTIONS} )
# set WITH_XSCREENSAVER to use XScreensaver for auto-away feature
@@ -68,9 +69,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings #################
-add_definitions(
- -DHAVE_CONFIG_H
-)
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
@@ -80,8 +79,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### konversation directories ##################
tde_conditional_add_subdirectory( BUILD_KONVERSATION konversation )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files #####################