summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-21 01:00:15 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-21 01:00:15 +0200
commit542c4844927089c9f9a9d376e51332d9d0d2d375 (patch)
treedb8f380bb342450569eb25e9de1a885436cbd631 /CMakeLists.txt
parentdc341c17b9359428a951dbd9312bec530f020b2b (diff)
downloadpotracegui-542c4844927089c9f9a9d376e51332d9d0d2d375.tar.gz
potracegui-542c4844927089c9f9a9d376e51332d9d0d2d375.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1984b1d..79141d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files