summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorormorph <roma251078@mail.ru>2024-04-28 17:36:28 +0300
committerormorph <roma251078@mail.ru>2024-04-28 22:36:17 +0300
commitf89c9441e67552f7a38cd46a7be2f399925eedf1 (patch)
tree74d374708648441fd3110b94c6a1e877c2e94ef1
parent11ea03a17b178450de6ef8889f3a86976b3d0166 (diff)
downloadtde-packaging-gentoo-f89c9441e67552f7a38cd46a7be2f399925eedf1.tar.gz
tde-packaging-gentoo-f89c9441e67552f7a38cd46a7be2f399925eedf1.zip
Added new style for twin tde-style-polyester
Signed-off-by: ormorph <roma251078@mail.ru>
-rw-r--r--trinity-apps/tde-style-polyester/Manifest1
-rw-r--r--trinity-apps/tde-style-polyester/metadata.xml8
-rw-r--r--trinity-apps/tde-style-polyester/tde-style-polyester-14.1.2.ebuild28
-rw-r--r--trinity-apps/tde-style-polyester/tde-style-polyester-9999.ebuild28
4 files changed, 65 insertions, 0 deletions
diff --git a/trinity-apps/tde-style-polyester/Manifest b/trinity-apps/tde-style-polyester/Manifest
new file mode 100644
index 00000000..d0b69baf
--- /dev/null
+++ b/trinity-apps/tde-style-polyester/Manifest
@@ -0,0 +1 @@
+DIST tde-style-polyester-trinity-14.1.2.tar.xz 205688 BLAKE2B 439bc159baf9acc85e5d96876aa80af4eddb0bd9890ec78ee8ecc9b17f7576111a2ff1d95b519f106d81ad14e281a1725b7a381cab836ef162916e21ff7f6618 SHA512 488746d7dc22a5dca332f2e979c242d637fee29d7d03e41c85c184fb674c58f0b2a9a086b7cd996c61810607835ebfcfcaefc4b5329f9fb14d5ed786d3080da9
diff --git a/trinity-apps/tde-style-polyester/metadata.xml b/trinity-apps/tde-style-polyester/metadata.xml
new file mode 100644
index 00000000..689e1534
--- /dev/null
+++ b/trinity-apps/tde-style-polyester/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>team-gentoo@trinitydesktop.org</email>
+ <name>Trinity Gentoo ebuilds project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/trinity-apps/tde-style-polyester/tde-style-polyester-14.1.2.ebuild b/trinity-apps/tde-style-polyester/tde-style-polyester-14.1.2.ebuild
new file mode 100644
index 00000000..d366f4c5
--- /dev/null
+++ b/trinity-apps/tde-style-polyester/tde-style-polyester-14.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="it pl"
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="Polyester widget style for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}
diff --git a/trinity-apps/tde-style-polyester/tde-style-polyester-9999.ebuild b/trinity-apps/tde-style-polyester/tde-style-polyester-9999.ebuild
new file mode 100644
index 00000000..d366f4c5
--- /dev/null
+++ b/trinity-apps/tde-style-polyester/tde-style-polyester-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="never"
+
+TRINITY_LANGS="it pl"
+
+TRINITY_MODULE_TYPE="applications/themes"
+inherit trinity-base-2
+
+DESCRIPTION="Polyester widget style for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}