summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-12-31 12:15:57 +0100
committerSlávek Banko <slavek.banko@axis.cz>2021-12-31 12:15:57 +0100
commit762bfec2c849854fc0247acf8d2f107c27b17940 (patch)
treedddce1b148241162ab70667fcd28cd421c7c8f14 /CMakeLists.txt
parentc3d0b8b21f6a174cd45213b6c3dcd85b203aafaa (diff)
downloadtdeaddons-762bfec2c849854fc0247acf8d2f107c27b17940.tar.gz
tdeaddons-762bfec2c849854fc0247acf8d2f107c27b17940.zip
Add option WITH_GCC_VISIBILITY.
Fix building with hidden visibility. Add missing definitions to config.h.cmake. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac2bbc2..3963ad8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,12 +41,13 @@ tde_setup_paths( )
##### optional stuff ############################
-option( WITH_ALL_OPTIONS "Enable all sane optional stuff" OFF )
-option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
-option( WITH_SDL "Enable SDL support" ${WITH_ALL_OPTIONS} )
-option( WITH_BERKELEY_DB "Enable Berkeley DB support" ${WITH_ALL_OPTIONS} )
-option( WITH_XMMS "Enable xmms support" OFF )
-option( WITH_TEST "Build tests" OFF )
+option( WITH_ALL_OPTIONS "Enable all sane optional stuff" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
+option( WITH_SDL "Enable SDL support" ${WITH_ALL_OPTIONS} )
+option( WITH_BERKELEY_DB "Enable Berkeley DB support" ${WITH_ALL_OPTIONS} )
+option( WITH_XMMS "Enable xmms support" OFF )
+option( WITH_TEST "Build tests" OFF )
##### options comments ##########################