summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2022-02-12 00:17:53 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2022-02-14 01:07:37 +0900
commitf9f7aee79eecdb610d71a8f2703de43e90018e5b (patch)
treedbb7075651157c6fad1d0aa027b503c95b5aa2e7 /CMakeLists.txt
parentf1df18afb54fd214430a2eb8416f632ffb8c64d1 (diff)
downloadtdebase-f9f7aee79eecdb610d71a8f2703de43e90018e5b.tar.gz
tdebase-f9f7aee79eecdb610d71a8f2703de43e90018e5b.zip
Removed HAL dependant code.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d49e28e09..a1ecfb6f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,7 +117,6 @@ option( WITH_XINERAMA "Enable xinerama extension support" ${WITH_ALL_OPTIONS} )
option( WITH_ARTS "Enable aRts support" ${WITH_ALL_OPTIONS} )
option( WITH_I8K "Enable Dell laptop support (ksysguard)" ${WITH_ALL_OPTIONS} )
option( WITH_SENSORS "Enable lm_sensors support (ksysguard)" ${WITH_ALL_OPTIONS} )
-option( WITH_HAL "Enable HAL support" OFF )
option( WITH_TDEHWLIB "Enable TDE hardware library support" ${WITH_ALL_OPTIONS} )
option( WITH_UPOWER "Enable UPOWER support" ${WITH_ALL_OPTIONS} )
option( WITH_ELFICON "Enable ELF embedded metadata support" ${WITH_ALL_OPTIONS} )
@@ -148,8 +147,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# WITH_ARTS affects libkonq khotkeys
# WITH_I8K affects ksysguard
# WITH_SENSORS affects ksysguard
-# WITH_HAL affects tdeioslaves(media) ksmserver kicker
-# WITH_TDEHWLIB affects tdeioslaves(media), replaces WITH_HAL on systems without HAL
+# WITH_TDEHWLIB affects tdeioslaves(media)
# WITH_LIBRAW1394 affects kcontrol(view1394)
# WITH_PAM affects tdm kdesktop kcheckpass
# WITH_SHADOW affects tdm kcheckpass