summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOBATA Akio <obache@wizdas.com>2020-08-19 16:51:24 +0900
committerSlávek Banko <slavek.banko@axis.cz>2020-09-27 19:06:55 +0200
commit70d26004f065c5fd18be00cab17fc93ed231d849 (patch)
tree65c457d44f29531ea13a8c77c9f6d252faaaa13c /CMakeLists.txt
parentba75e441eab1713cac9219d93d06c478c0bc93df (diff)
downloadtdelibs-70d26004f065c5fd18be00cab17fc93ed231d849.tar.gz
tdelibs-70d26004f065c5fd18be00cab17fc93ed231d849.zip
Add an ability to specify default spell checker
There is no reason to determine it with operating system basis. Change to use build configuration instead. "ispell" by default, and you can override it. Signed-off-by: OBATA Akio <obache@wizdas.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c9ae8384c..dc06d3b62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1257,6 +1257,10 @@ if( WITH_HSPELL )
endif( WITH_HSPELL )
+####" default spell checker #####################
+set( DEFAULT_SPELL_CHECKER "ISPELL" CACHE STRING "default spell checker" )
+
+
##### enable TDEIconLoader debugging ############
if ( WITH_TDEICONLOADER_DEBUG )