summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40130e63..25c4d84d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,7 +67,7 @@ option( WITH_MUSICBRAINZ "Enable MusicBrainz support (juk)" OFF )
option( WITH_TAGLIB "Enable taglib support (juk, tdefile-plugins)" ${WITH_ALL_OPTIONS} )
option( WITH_THEORA "Enable Ogg/Theora support (tdefile-plugins)" ${WITH_ALL_OPTIONS} )
option( WITH_VORBIS "Enable Ogg/Vorbis support (krec, mpeglib, oggarts, tdefile-plugins)" ${WITH_ALL_OPTIONS} )
-
+option( WITH_KMIX_EXPERIMENTAL "Enable experimental/unmaintained KMix features" OFF )
##### user requested modules ####################
@@ -141,6 +141,11 @@ if( BUILD_KAUDIOCREATOR )
add_subdirectory( kaudiocreator )
endif( BUILD_KAUDIOCREATOR )
tde_conditional_add_subdirectory( BUILD_KMIX kmix )
+if( WITH_KMIX_EXPERIMENTAL )
+ if( NOT BUILD_KMIX )
+ tde_message_fatal( "KMix experimental features requested, but KMix won't be built" )
+ endif( )
+endif( WITH_KMIX_EXPERIMENTAL )
if( BUILD_KREC )
if( NOT BUILD_ARTS )
tde_message_fatal( "krec can not be built without building arts" )