summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:52:11 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:09:18 +0900
commit5078bedfdce40325ca513ed3f98da022e856e50c (patch)
tree86b76eafd4ec213d850333660d90654ceee4df0c /CMakeLists.txt
parent3d8bcf0b07ce88fc1c3b9f48a5b260df75287a57 (diff)
downloadkdiff3-5078bedfdce40325ca513ed3f98da022e856e50c.tar.gz
kdiff3-5078bedfdce40325ca513ed3f98da022e856e50c.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c2b8fa..7558622 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )