summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-06-27 14:46:01 +0200
committergregory guy <gregory-tde@laposte.net>2020-06-27 14:46:01 +0200
commite14732aa76b0fc20b955da434b1e2e92012c34e8 (patch)
tree5dfb589ae107ddaa2288783aa78f80b5dc3ff894 /CMakeLists.txt
parenteadb41b09fb5d6e46cf98c0d6dee1723c8307d89 (diff)
downloadkdiff3-e14732aa76b0fc20b955da434b1e2e92012c34e8.tar.gz
kdiff3-e14732aa76b0fc20b955da434b1e2e92012c34e8.zip
Drop automake build support.
Add basic cmake build instructions. Delete the NEWS file. Rework of the README. The man folder has been moved into the doc folder for consistency with what have been done so far. The html pages have been moved into the doc folder as well. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 6 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7a9edb..2061e1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -70,10 +70,8 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( src )
add_subdirectory( kdiff3plugin )
-tde_conditional_add_subdirectory( BUILD_DOC man )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_DOC data/doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS kdiff3plugin/po )