summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-18 21:05:14 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-18 21:05:14 +0200
commit6902a1c5ee59b38b1fd40ec8f1bf5c38810c5c3c (patch)
treefb78fe6f7d6016b1adf988af4092fcd37601e160 /CMakeLists.txt
parent3fc9684db5b7d0b2de38ecf1748cceed25943181 (diff)
downloadknights-6902a1c5ee59b38b1fd40ec8f1bf5c38810c5c3c.tar.gz
knights-6902a1c5ee59b38b1fd40ec8f1bf5c38810c5c3c.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68ba259..c4eca99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,11 +71,15 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( media )
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
tde_conditional_add_subdirectory( BUILD_EXTRA_THEME extra-theme )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
##### write configure files
configure_file( config.h.cmake config.h @ONLY )