summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:52:23 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:12:38 +0900
commit04f0d6610b4904056926f2dab1354bd5a85bf34d (patch)
treeff580858405563c3886e520c69ef94ad105f2b29 /CMakeLists.txt
parent07106c0a34f021d33eecae6571f0a67c990081bd (diff)
downloadkpicosim-04f0d6610b4904056926f2dab1354bd5a85bf34d.tar.gz
kpicosim-04f0d6610b4904056926f2dab1354bd5a85bf34d.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14215b7..63e2f61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )