summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-10 19:33:14 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-10 19:33:14 +0100
commitfdd508d2999441099da89dddedd98bde036e82a7 (patch)
tree86fb18a93595105031db37257d4be97cd23bf7e4 /CMakeLists.txt
parent5fc3ae36c8e07ed7157b04ce25b7339a119be471 (diff)
downloadkpicosim-fdd508d2999441099da89dddedd98bde036e82a7.tar.gz
kpicosim-fdd508d2999441099da89dddedd98bde036e82a7.zip
Add CMakeL10n rules.
Create translation template. Add CMake rules to build translations. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee3b515..5cb9866 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
option( BUILD_ALL "Build all" ON )
option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -68,6 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
add_subdirectory( src )
tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
##### write configure files