summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-05-26 01:30:17 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-05-26 01:30:17 +0200
commit5004b40e99036a0d9346dba6b5e6a4553de5a65e (patch)
treed7f9d99920bfff3b4a5719446ead1c3951ec5399 /CMakeLists.txt
parent8bc51aef53e4d9de236ca4f19806b32da1cc0525 (diff)
downloadkscope-5004b40e99036a0d9346dba6b5e6a4553de5a65e.tar.gz
kscope-5004b40e99036a0d9346dba6b5e6a4553de5a65e.zip
Fix missing or incorrect ascii conversions when retrieving process output.
Added controlled conversions to char* instead of automatic ascii conversions. The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76d0986..a4d770d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,7 +60,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )