summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:56:10 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:13:49 +0900
commit91de11bf8d6e89d44d581efd5eb2ebd846017ab2 (patch)
tree1f5fcb3dc96c846cfa34c2ee36624fe3ec34d5e7 /CMakeLists.txt
parent50d320ef3acab207a4fc614a80fb4fd1c01aa08a (diff)
downloadkstreamripper-91de11bf8d6e89d44d581efd5eb2ebd846017ab2.tar.gz
kstreamripper-91de11bf8d6e89d44d581efd5eb2ebd846017ab2.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8abbac9..61c6625 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )