summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in220
1 files changed, 0 insertions, 220 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 71a2b25..0000000
--- a/configure.in
+++ /dev/null
@@ -1,220 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was Kalle@kde.org
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(kuickshow, "3.5.8") dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-dnl KDE_USE_TQT
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG
-DO_NOT_COMPILE="$DO_NOT_COMPILE"
-
-dnl Checks for header files.
-AC_HEADER_DIRENT
-AC_HEADER_STDC
-AC_CHECK_HEADERS(fcntl.h sys/time.h unistd.h stdlib.h paths.h)
-AC_CHECK_SETENV
-AC_CHECK_UNSETENV
-AC_CHECK_USLEEP
-AC_CHECK_MKSTEMPS
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_HEADER_TIME
-
-CXXFLAGS="$CXXFLAGS $KDE_DEFAULT_CXXFLAGS"
-
-KDE_INIT_DOXYGEN([KDE Graphics API Reference], [Version $VERSION])
-dnl =======================================================
-dnl FILE: ./kuickshow/configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG
-
-#dnl PACKAGE set before
-
-# my own additions to KDE's version
-#
-# checking for Imlib...
-
-AC_DEFUN([KDE_FIND_IMLIB_CONFIG],
- [AC_MSG_CHECKING([for imlib-config])
-
-imlib_config_given=NO
-ac_imlib_config=""
-
-AC_ARG_WITH(imlib-config,
-AC_HELP_STRING([--with-imlib-config=DIR],[directory where "imlib-config" is located]),
-[ ac_imlib_config="$withval/imlib-config"
- imlib_config_given=yes
-])
-
-if test "$imlib_config_given" = "yes"; then
- if test ! -r $ac_imlib_config; then
- AC_MSG_RESULT(wrong file specified)
- ac_imlib_config=""
- else
- AC_MSG_RESULT($ac_imlib_config)
- LIB_IMLIB=`$ac_imlib_config --libs`
- AC_SUBST(LIB_IMLIB)
- fi
-else
- ac_imlib_config=`which imlib-config 2>/dev/null`
- if test -z "$ac_imlib_config"; then
- AC_MSG_RESULT(no)
- else
- dummy=`echo "$ac_imlib_config" | grep '/imlib-config'`
- if test -z "$dummy"; then
- AC_MSG_RESULT(no)
- ac_imlib_config=""
- else
- LIB_IMLIB=`$ac_imlib_config --libs`
- IMLIB_CFLAGS=`$ac_imlib_config --cflags`
- imlib_config=`echo "$LIB_IMLIB" | grep lImlib`
- if test -z "$imlib_config"; then
- AC_MSG_RESULT(no)
- ac_imlib_config=""
- else
- AC_SUBST(LIB_IMLIB)
- AC_SUBST(IMLIB_CFLAGS)
- AC_MSG_RESULT($ac_imlib_config)
- fi
- fi
- fi
-fi
-
-])
-
-dnl #### now some kuickshow stuff ###
-dnl Check if Imlib is installed properly
-KDE_PKG_CHECK_MODULES(IMLIB, imlib >= 1.9.10,
- LIB_IMLIB=$IMLIB_LIBS
- AC_SUBST(LIB_IMLIB)
-,
-KDE_FIND_IMLIB_CONFIG
-)
-
-if test -z "$LIB_IMLIB"; then
-dnl AC_MSG_ERROR([You need to install Imlib 1.x, e.g. http://freshmeat.net/redir/imlib/4385/url_tgz/imlib-1.9.10.tar.gz if your distributor doesn't have a package])
- DO_NOT_COMPILE="$DO_NOT_COMPILE kuickshow"
-fi
-KDE_CREATE_SUBDIRSLIST
-AM_CONDITIONAL(doc_SUBDIR_included, test "x$doc_SUBDIR_included" = xyes)
-AM_CONDITIONAL(kuickshow_SUBDIR_included, test "x$kuickshow_SUBDIR_included" = xyes)
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ doc/kuickshow/Makefile ])
-AC_CONFIG_FILES([ kuickshow/Makefile ])
-AC_CONFIG_FILES([ kuickshow/misc/Makefile ])
-AC_CONFIG_FILES([ kuickshow/pics/Makefile ])
-AC_CONFIG_FILES([ kuickshow/src/Makefile ])
-AC_OUTPUT
-if test -z "$LIB_IMLIB"; then
- echo ""
- echo "You're missing Imlib 1.x. The graphics browser/viewer KuickShow"
- echo "won't be compiled without Imlib."
- echo "You can download it from"
- echo "http://freshmeat.net/redir/imlib/4385/url_tgz/imlib-1.9.10.tar.gz"
- echo ""
- all_tests=bad
-fi
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi