summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 10:52:53 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-17 11:14:33 +0900
commited48d312ff120915c68cd8ead0a41dc0a0788232 (patch)
tree44819ff556126b42f5e1e6a894b84a4f9d7cc3e1 /CMakeLists.txt
parent41b3c136fb316a7db9dcacde48890ca716422395 (diff)
downloadkxmleditor-ed48d312ff120915c68cd8ead0a41dc0a0788232.tar.gz
kxmleditor-ed48d312ff120915c68cd8ead0a41dc0a0788232.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c67ad9a..2131d7d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )