summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-01 18:55:11 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2010-03-01 18:55:11 +0000
commit854bf52eebd2da47ff45f6ae85f4cb89bae89876 (patch)
tree24fa0a7eabb9c300a1655d665f72327fe5ab3464 /Makefile.am
downloadsmb4k-854bf52eebd2da47ff45f6ae85f4cb89bae89876.tar.gz
smb4k-854bf52eebd2da47ff45f6ae85f4cb89bae89876.zip
Added old KDE3 version of SMB4K
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/smb4k@1097609 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..ddfca88
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,21 @@
+if compile_konqplugin
+ PLUGINDIR=plugin
+endif
+
+EXTRA_DIST = admin AUTHORS COPYING ChangeLog INSTALL README TODO smb4k.lsm BUGS FAQ
+
+AUTOMAKE_OPTIONS = foreign 1.5
+
+MAINTAINERCLEANFILES = subdirs configure.in acinclude.m4 configure.files
+
+package-messages:
+ $(MAKE) -f admin/Makefile.common package-messages
+ $(MAKE) -C po merge
+
+#include admin/deps.am
+
+SUBDIRS = smb4k $(PLUGINDIR) utilities po doc
+
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) `find . -name \*.cpp` -o $(podir)/smb4k.pot