summaryrefslogtreecommitdiffstats
path: root/app-eselect
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-26 12:59:42 +0100
committerChris <xchrisx@uber.space>2020-03-26 12:59:42 +0100
commit173015ae98f2409961976f77c4350217fece06d2 (patch)
tree2ca8cc9fa67f910696de140f5d78d3d14285b8a0 /app-eselect
parentc164cbfdd0a6a7f35dd66b5f0f2454faca4edcb0 (diff)
downloadtde-packaging-gentoo-173015ae98f2409961976f77c4350217fece06d2.tar.gz
tde-packaging-gentoo-173015ae98f2409961976f77c4350217fece06d2.zip
Add `pinentry` ebuild as TQt version.
Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-pinentry/Manifest2
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild22
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.712
3 files changed, 36 insertions, 0 deletions
diff --git a/app-eselect/eselect-pinentry/Manifest b/app-eselect/eselect-pinentry/Manifest
new file mode 100644
index 00000000..ebb967f6
--- /dev/null
+++ b/app-eselect/eselect-pinentry/Manifest
@@ -0,0 +1,2 @@
+AUX pinentry.eselect-0.7 419 BLAKE2B 0628d715d942f55124545fcef1060cbae4629039902f920358d5e56433dc682b5ed313d3537814f8c134d9ac96fc59f9811179c6793339ee7f67eb907cb1def0 SHA512 07f3e6acaa9e2451f5978b5ef1b509e86d962f4b792339503c6f232566f7f22ecd6842f4828384366a3e6f0259bf899988678667366b321074c235ce6e2338e3
+EBUILD eselect-pinentry-0.7.ebuild 690 BLAKE2B efa5f15c50e8cd136e7988ccd78dc8fe9e29b20912816002f9a1fe2e19f9c59bda9774eb6d914ebcffbea5bce44a315fd4381e6cf02b0484c96c0e4bc4c1a3b4 SHA512 ba1107a5113bd3bd51b647d01ffe327915d5c0472b049e9602f8022bf0a3d33c113a2b16fc11ac626942272326b39936507f20710c28f2341e39f1612b0f2783
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
new file mode 100644
index 00000000..1cc024f4
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~riscv s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+S="${FILESDIR}"
+
+src_install() {
+ default
+ insinto /usr/share/eselect/modules
+ newins pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7
new file mode 100644
index 00000000..896981d2
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7
@@ -0,0 +1,12 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="ssuominen@gentoo.org"
+VERSION="0.7"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=( pinentry-gnome3 pinentry-qt pinentry-tqt pinentry-gtk-2 pinentry-qt4 pinentry-curses pinentry-tty )
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink