summaryrefslogtreecommitdiffstats
path: root/app-text
diff options
context:
space:
mode:
authorChris <xchrisx@uber.space>2020-03-30 23:37:16 +0200
committerTDE Gitea <gitea@mirror.git.trinitydesktop.org>2020-03-31 16:35:37 +0000
commit3ad534419b773150d7b483914d241bbf554fbbc5 (patch)
tree27e447393a1efe11addfc9183b5686df61ae6b12 /app-text
parenteefc54ceb5ebebce82cc219a74c117781149f1b2 (diff)
downloadtde-packaging-gentoo-3ad534419b773150d7b483914d241bbf554fbbc5.tar.gz
tde-packaging-gentoo-3ad534419b773150d7b483914d241bbf554fbbc5.zip
Live ebuilds: Add `Ispell` ebuild and support to `tdelibs`.
Also: Fix typos and sync with stable. Signed-off-by: Chris <xchrisx@uber.space>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ispell/Manifest1
-rw-r--r--app-text/ispell/ispell-3.4.00.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-text/ispell/Manifest b/app-text/ispell/Manifest
new file mode 100644
index 00000000..6e0cddeb
--- /dev/null
+++ b/app-text/ispell/Manifest
@@ -0,0 +1 @@
+DIST ispell-3.4.00.tar.gz 638770 BLAKE2B 889216df875ebaea617522a416ca7317c593d071bbe0ad3465bd23191ea9720a88530c2e7f27ddc9dae1ddd2742fa92f9451647e70eac98080ad58694e39a29f SHA512 790475e7e296554221679b59856f256889a7193ab39e7314174f92364eaf4b658cc7e6b4f4b7892fa8f3cf0c022d933fc0c995c5e414987cbdcde27723e3da31
diff --git a/app-text/ispell/ispell-3.4.00.ebuild b/app-text/ispell/ispell-3.4.00.ebuild
new file mode 100644
index 00000000..3f92dfa7
--- /dev/null
+++ b/app-text/ispell/ispell-3.4.00.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors and Martin V\"ath
+# Copyright 2020 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+RESTRICT="mirror"
+inherit toolchain-funcs
+
+DESCRIPTION="fast screen-oriented spelling checker"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0/3.4.00"
+KEYWORDS="alpha amd64 ~arm hppa ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+ sys-apps/miscfiles
+ sys-libs/ncurses:0=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/usr/local/man:'"${EPREFIX}"'/usr/share/man:' \
+ -e 's:/usr/local/lib:'"${EPREFIX}"'/usr/'"$(get_libdir)/${PN}:" \
+ -e 's:/usr/local:'"${EPREFIX}"'/usr:' \
+ -- "${S}"/local.h.* || die
+ sed -i \
+ -e 's:\(^#define CC\).*:\1 "'"$(tc-getCC)"'":' \
+ -e 's:\(^#define CFLAGS\).*:\1 "'"-ltinfo ${CFLAGS}"'":' \
+ -- "${S}"/config.X || die
+ default
+}
+
+src_configure() {
+ # Prepare config.sh for installation phase to avoid twice rebuild
+ emake -j1 config.sh
+ sed \
+ -e "s:^\(BINDIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(LIBDIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(MAN1DIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ -e "s:^\(MAN45DIR='\)${EPREFIX}\(/usr.*\):\1${ED}\2:" \
+ < config.sh > config.sh.install
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ mv config.sh.install config.sh
+ emake -j1 install
+ dodoc CHANGES Contributors README WISHES
+}