summaryrefslogtreecommitdiffstats
path: root/trinity-base/kdesktop/kdesktop-14.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/kdesktop/kdesktop-14.1.0.ebuild')
-rw-r--r--trinity-base/kdesktop/kdesktop-14.1.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/trinity-base/kdesktop/kdesktop-14.1.0.ebuild b/trinity-base/kdesktop/kdesktop-14.1.0.ebuild
deleted file mode 100644
index 0cc928c3..00000000
--- a/trinity-base/kdesktop/kdesktop-14.1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Copyright 2020-2023 The Trinity Desktop Project
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-TRINITY_MODULE_NAME="tdebase"
-TRINITY_MODULE_TYPE="core"
-TSM_EXTRACT_ALSO="kcheckpass/ FindXscreensaver.cmake"
-inherit trinity-meta-2
-
-DESCRIPTION="The part of TDE UI that handles icons, desktop, screensaver etc"
-if [[ ${PV} != *9999* ]] ; then
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-IUSE="pam xscreensaver hwlib"
-
-COMMON_DEPEND="
- ~dev-libs/dbus-1-tqt-${PV}
- ~trinity-base/kcontrol-${PV}
- ~trinity-base/libkonq-${PV}
- x11-libs/libXrender
- x11-libs/libXcursor
- xscreensaver? ( x11-libs/libXScrnSaver )"
- # Requires the desktop background settings module,
- # so until we separate the kcontrol modules into separate ebuilds :-),
- # there's a dep here
-DEPEND="${COMMON_DEPEND}
- xscreensaver? ( x11-base/xorg-proto x11-misc/xscreensaver )"
-RDEPEND="${COMMON_DEPEND}
- ~trinity-base/kcheckpass-${PV}
- ~trinity-base/kdialog-${PV}
- ~trinity-base/konqueror-${PV}
- pam? ( trinity-base/tdebase-pam )"
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_XCURSOR=ON
- -DWITH_XRENDER=ON
- -DWITH_PAM="$(usex pam)"
- -DWITH_XSCREENSAVER="$(usex xscreensaver)"
- -DTDESCREENSAVER_PAM_SERVICE=tde
- -DWITH_TDEHWLIB="$(usex hwlib)"
- )
- trinity-meta-2_src_configure
-}