summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 11:18:14 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-03-15 12:03:15 +0900
commit87a308d742df751876c748aabba36ebfa8973f18 (patch)
tree7a6bcc5cdd07706dfcbfbe7b52162badd611f6c5 /CMakeLists.txt
parent872d31ed9082c412cdf510091ff33df6ada957ed (diff)
downloadtdeaccessibility-87a308d742df751876c748aabba36ebfa8973f18.tar.gz
tdeaccessibility-87a308d742df751876c748aabba36ebfa8973f18.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0b290f0..e855b2b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -33,11 +37,6 @@ include( TDEMacros )
enable_testing( )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )