summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2021-04-26 18:43:25 +0200
committergregory guy <gregory-tde@laposte.net>2021-05-20 20:16:35 +0200
commit749694a3f2fecddf44633067c24851d8719b181e (patch)
tree27c58f5c28223c8ae9aa5a01409a5e12ff0c52ca /CMakeLists.txt
parentb0ef1b76e6bc94f5a8a35b9a43573eab81bca459 (diff)
downloadtdeartwork-749694a3f2fecddf44633067c24851d8719b181e.tar.gz
tdeartwork-749694a3f2fecddf44633067c24851d8719b181e.zip
asciiquarium: Add cmake build support, app is renamed tdeasciiquarium.
Signed-off-by: gregory guy <gregory-tde@laposte.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt117
1 files changed, 61 insertions, 56 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1960221..0423fce3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,18 +1,18 @@
-#################################################
-#
-# (C) 2011 Golubev Alexander
-# fatzer2 (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
+###########################################
+# #
+# (C) 2011 Golubev Alexander #
+# fatzer2 (AT) gmail.com #
+# #
+# Improvements and feedback are welcome #
+# #
+# This file is released under GPL >= 2 #
+# #
+###########################################
cmake_minimum_required( VERSION 2.8.12 )
-##### general package setup #####################
+##### general package setup
project( tdeartwork )
@@ -20,7 +20,7 @@ set( PACKAGE tdeartwork )
set( VERSION R14.1.0 )
-##### include essential cmake modules ###########
+##### include essential cmake modules
include( FindPkgConfig )
include( CheckIncludeFile )
@@ -29,79 +29,84 @@ include( CheckCXXSourceCompiles )
include( CheckSymbolExists )
-##### include our cmake modules #################
+##### include our cmake modules
set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
-##### setup install paths #######################
+##### setup install paths
include( TDESetupPaths )
tde_setup_paths( )
-##### optional stuff ############################
+##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_XSCREENSAVER "Enable xscreensavers support" ${WITH_ALL_OPTIONS} )
+option( WITH_ALL_INCLUDED_XSCREENSAVERS "Install all included desktop files" OFF ) #regardless of the presence of XML
+option( WITH_LIBART "Enable libart support" ${WITH_ALL_OPTIONS} )
+option( WITH_OPENGL "Enable 3D GL modes" ${WITH_ALL_OPTIONS} )
+option( WITH_ARTS "Enable aRts support" OFF )
-option( WITH_XSCREENSAVER "Enable xscreensavers support" ${WITH_ALL_OPTIONS} )
-option( WITH_ALL_INCLUDED_XSCREENSAVERS
- "Install all included desktop files regardless of the presence of XML" OFF )
-option( WITH_LIBART "Enable libart support" ${WITH_ALL_OPTIONS} )
-option( WITH_OPENGL "Enable 3D GL modes" ${WITH_ALL_OPTIONS} )
-option( WITH_ARTS "Enable aRts support" OFF )
+########### options comments ##############
+# #
+# affects tdescreensaver build: #
+# #
+# WITH_XSCREENSAVER #
+# WITH_ALL_INCLUDED_XSCREENSAVERS #
+# WITH_LIBART #
+# WITH_OPENGL #
+# WITH_ARTS #
+# #
+##############################################
-##### options comments ##########################
-
-# WITH_XSCREENSAVER affects tdescreensaver
-# WITH_ALL_INCLUDED_XSCREENSAVERS affects tdescreensaver
-# WITH_LIBART affects tdescreensaver
-# WITH_OPENGL affects tdescreensaver
-# WITH_ARTS affects tdescreensaver
# NOTE: These flags control which screensavers are compiled/installed.
-##### user requested modules ####################
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_EMOTICONS "Build emoticons" ${BUILD_ALL} )
+option( BUILD_ICEWM_THEMES "Build icewm-themes" ${BUILD_ALL} )
+option( BUILD_ICON_THEMES "Build icon themes" ${BUILD_ALL} )
+option( BUILD_TDESCREENSAVER "Build tdescreensaver" ${BUILD_ALL} )
+option( BUILD_TWIN_STYLES "Build twin styles" ${BUILD_ALL} )
+option( BUILD_KWORLDCLOCK "Build kworldclock" ${BUILD_ALL} )
+option( BUILD_SOUNDS "Build sounds" ${BUILD_ALL} )
+option( BUILD_STYLES "Build styles" ${BUILD_ALL} )
+option( BUILD_WALLPAPERS "Build wallpapers" ${BUILD_ALL} )
+option( BUILD_TDEASCIIQUARIUM "Build tdeasciiquarium screen saver" ${BUILD_ALL} )
-option( BUILD_ALL "Build all" OFF )
-option( BUILD_EMOTICONS "Build emoticons" ${BUILD_ALL} )
-option( BUILD_ICEWM_THEMES "Build icewm-themes" ${BUILD_ALL} )
-option( BUILD_ICON_THEMES "Build icon themes" ${BUILD_ALL} )
-option( BUILD_TDESCREENSAVER "Build tdescreensaver" ${BUILD_ALL} )
-option( BUILD_TWIN_STYLES "Build twin styles" ${BUILD_ALL} )
-option( BUILD_KWORLDCLOCK "Build kworldclock" ${BUILD_ALL} )
-option( BUILD_SOUNDS "Build sounds" ${BUILD_ALL} )
-option( BUILD_STYLES "Build styles" ${BUILD_ALL} )
-option( BUILD_WALLPAPERS "Build wallpapers" ${BUILD_ALL} )
-##### configure checks ##########################
+##### configure checks
include( ConfigureChecks.cmake )
-###### global compiler settings #################
-add_definitions(
- -DHAVE_CONFIG_H
-)
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
-##### tdenetwork directories ####################
+##### tdenetwork directories
+
+tde_conditional_add_subdirectory( BUILD_EMOTICONS emoticons )
+tde_conditional_add_subdirectory( BUILD_ICEWM_THEMES icewm-themes )
+tde_conditional_add_subdirectory( BUILD_ICON_THEMES IconThemes )
+tde_conditional_add_subdirectory( BUILD_TDESCREENSAVER tdescreensaver )
+tde_conditional_add_subdirectory( BUILD_TWIN_STYLES twin-styles )
+tde_conditional_add_subdirectory( BUILD_KWORLDCLOCK kworldclock )
+tde_conditional_add_subdirectory( BUILD_SOUNDS sounds )
+tde_conditional_add_subdirectory( BUILD_STYLES styles )
+tde_conditional_add_subdirectory( BUILD_WALLPAPERS wallpapers )
-tde_conditional_add_subdirectory( BUILD_EMOTICONS emoticons )
-tde_conditional_add_subdirectory( BUILD_ICEWM_THEMES icewm-themes )
-tde_conditional_add_subdirectory( BUILD_ICON_THEMES IconThemes )
-tde_conditional_add_subdirectory( BUILD_TDESCREENSAVER tdescreensaver )
-tde_conditional_add_subdirectory( BUILD_TWIN_STYLES twin-styles )
-tde_conditional_add_subdirectory( BUILD_KWORLDCLOCK kworldclock )
-tde_conditional_add_subdirectory( BUILD_SOUNDS sounds )
-tde_conditional_add_subdirectory( BUILD_STYLES styles )
-tde_conditional_add_subdirectory( BUILD_WALLPAPERS wallpapers )
-##### write configure files #####################
+##### write configure files
configure_file( config.h.cmake config.h @ONLY )