summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-01-10 20:42:02 -0600
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2015-01-10 20:42:02 -0600
commit710a9c7c320fab11ac523662b93140c14e8163a4 (patch)
tree88fc9aeabaf5372bfe6ece2b30ff0538d36f7bb9 /CMakeLists.txt
parentf6187cc4eb8a8726f5b64f0c640ac8d2355b85eb (diff)
downloadtdenetwork-710a9c7c320fab11ac523662b93140c14e8163a4.tar.gz
tdenetwork-710a9c7c320fab11ac523662b93140c14e8163a4.zip
Use latest libvncserver module for krfb
This relates to Bug 1582 among others
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81df9962..857b9ad4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -144,6 +144,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### tdenetwork directories ####################
+if (BUILD_KRDC OR BUILD_KRFB)
+ set ( BUILD_LIBTDEVNC ON )
+endif (BUILD_KRDC OR BUILD_KRFB)
+
+tde_conditional_add_subdirectory( BUILD_LIBTDEVNC libtdevnc )
tde_conditional_add_subdirectory( BUILD_DCOPRSS dcoprss )
tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_FILESHARING filesharing )