summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47ebdd9..c644bd0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,6 +34,11 @@ include( FindPkgConfig )
include( TDEMacros )
+##### set version number ########################
+
+tde_set_project_version( )
+
+
##### setup install paths #######################
include( TDESetupPaths )
@@ -64,11 +69,10 @@ ENDIF(BUILD_TESTS)
##### versioning ################################
SET(BASE_VERSION 1.0.4)
-SET(VERSION "$ENV{KDESVN_VERSION}")
-IF(NOT VERSION)
- SET(VERSION ${BASE_VERSION})
-ENDIF(NOT VERSION)
-SET(KDESVN_VERSION \"${VERSION}\")
+SET(KDESVN_VERSION "$ENV{KDESVN_VERSION}")
+IF(NOT KDESVN_VERSION)
+ SET(KDESVN_VERSION ${BASE_VERSION})
+ENDIF(NOT KDESVN_VERSION)
##### configure checks ##########################