summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-24 19:39:12 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-24 19:39:12 +0000
commit95871d87ebbbd12b74946c8bbe02ed4577fb7ce2 (patch)
treee4574c827bca24c3fccba5905e36dcb1696723b6 /CMakeLists.txt
parent5ee15978933b6a6a6f37b1a033c0ef797f78778d (diff)
downloadtdewebdev-95871d87ebbbd12b74946c8bbe02ed4577fb7ce2.tar.gz
tdewebdev-95871d87ebbbd12b74946c8bbe02ed4577fb7ce2.zip
[kdewebdev/kfilereplace] initial cmake support
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdewebdev@1216788 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6edbed73..7e94b24c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,7 +51,8 @@ tde_setup_paths( )
##### user requested modules ####################
option( BUILD_ALL "Build all" OFF )
-option( BUILD_QUANTA "Build Quanta" ${BUILD_ALL} )
+option( BUILD_KFILEREPLACE "Build kfilereplace" ${BUILD_ALL} )
+option( BUILD_QUANTA "Build quanta" ${BUILD_ALL} )
##### configure checks ##########################
@@ -73,7 +74,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### source directories ########################
-add_subdirectory( lib )
+if( BUILD_QUANTA )
+ add_subdirectory( lib )
+endif( )
+
+tde_conditional_add_subdirectory( BUILD_KFILEREPLACE kfilereplace )
tde_conditional_add_subdirectory( BUILD_QUANTA quanta )